Official HTC Froyo (2.2) image for Desire


Here’s official image from HTC, which may contain latest update for HTC Desire up to Froyo (version 2.2). Please, don’t forget to update radio, because Froyo requires at least version 5 and won’t work with outdated version 4.

, ,

  1. #1 by lenik on May 26, 2011 - 22:43

    http://liveimage.htc.com/ shows default apache page, probably they have messed up the server. I hope it will become available again soon.

Comments are closed.